CPU cooling

I decided to add a second fan to the radiator of the CPU’s liquid cooler (a pre-filled self contained unit that came with the system) to get a push-pull cooling configuration. The air being blown out the case seemed a little on the warm side, so I figured a second fan would help keep things cooler.
The fan is a Scythe S-FLEX 120 mm case fan (which seems to have been just deactivated on Newegg…maybe I bought their last one). The original radiator fan started buzzing so I purchased one to replace it. Now there are two of them blowing air through the radiator. Really nice fan, very quiet, which is why I bought another one.
Getting more air flow through the radiator now, and the exhausted air feels a little bit cooler.
Then I thought “I wonder what the motherboard thinks the CPU temperature is”. I had never bothered to monitor any of the motherboard sensors before. After a little bit of searching, I installed lm-sensors.
If the output of sensors is to be believed, then the CPU cores at idle are running around 45-47°C.
Core 0: +45.0°C (high = +80.0°C, crit = +100.0°C)
Core 1: +46.0°C (high = +80.0°C, crit = +100.0°C)
Core 2: +47.0°C (high = +80.0°C, crit = +100.0°C)
Core 3: +45.0°C (high = +80.0°C, crit = +100.0°C)
Seems pretty high to me. I’d have expected something in the 30s.
Starting up the distributed.net client drives up the detected temperature into the high 80s.
Core 0: +86.0°C (high = +80.0°C, crit = +100.0°C)
Core 1: +89.0°C (high = +80.0°C, crit = +100.0°C)
Core 2: +83.0°C (high = +80.0°C, crit = +100.0°C)
Core 3: +85.0°C (high = +80.0°C, crit = +100.0°C)
Whoa. Way high, and much higher than I expected.
So now I’m starting wonder: is the motherboard temperature sensor accurate? Is there a problem with the cooling block? Should I take it off and inspect it? Maybe it’s time for another cooler?
The other thing I need to do is check the temperatures reported by the BIOS to see how it compares. I think a little investigation is in order.
Update: BIOS shows pretty much the same temperature (~47°C). Definitely time for some investigating. These temps just seem a little higher than they should be.
Update 2: A little bit of Google’ing shows that idle temps in the 40s aren’t unusual for the i7-930. My temps are still a little on the high end of the range that I’ve been seeing. Maybe a cooler upgrade is in my future soon. The Corsair H70 looks nice.
Update 3: The second fan seems to be helping. Under distributed.net load, the CPU is running in the low 70s now
Core 0: +73.0°C (high = +80.0°C, crit = +100.0°C)
Core 1: +75.0°C (high = +80.0°C, crit = +100.0°C)
Core 2: +71.0°C (high = +80.0°C, crit = +100.0°C)
Core 3: +72.0°C (high = +80.0°C, crit = +100.0°C)